Jump to content
CameraBag & Fotograf Forums
Nicko

camerabag crashes with large files

Recommended Posts

I find that camerabag crashes if I try to save a large file (typically 8600 x 5733, 30 to 40Mb). You make adjustments and when you come to SAVE, Camerbag just crashes and there is a windows message saying it will look for any soutions to the problem, but the problem itself is not defined.

Any ideas how this can be solved?

Share this post


Link to post
Share on other sites

Hmm, are you on Mac or PC? How much RAM do you have? We'll see if we can recreate this, or it would be extremely helpful if you could send us a file (to support@nevercenter.com with a link to this post). Thanks!

Share this post


Link to post
Share on other sites

THANKS FOR YOUR REPLY - it went in the junk file so it's lucky I spotted it!

1) PC - 16Gb RAM, I7 clocked around 3.4Ghz etc etc

2) Do you want me to try send you a complete 30Mb file? This might be too big for hotmail but I can arrange download from a cloud.

3) As an experiment I loaded Camerabag on another I7 computer, also 16Gb, but running Windows 7 (the other is 8.1) and basically the same problems.

4) I also find the problem more erratic, as I have tried larger and smaller files both pixel and Mb wise and the crashing is a bit indeterminate. Sometimes it

does it, sometimes it doesn't, on medium to small files.

5) The problem seems to be related to dll files.

IN GENERAL and looking on the good side  if you want to see kind of extreme effects I have created with Camerabag post-producing off Paint Shop Pro, see

or

 

 

Thanks

Nick

Share this post


Link to post
Share on other sites

Things are getting worse. Camerabag either crashes immediately I try save, or even will not run because some dll file missing.

Can you help?

Share this post


Link to post
Share on other sites

Hi Nicko, yes please send us a link to the whole file if possible and we'll download it and take a look.

We can't imagine why you're getting a missing .dll message. Could you maybe take a screenshot or let us know which dll file specifically is missing?

Also, those are really cool videos!

Share this post


Link to post
Share on other sites

John

 

Many thanks, and I couldn't get some of those effects with camerabag - it's an essential tool.

 

This is a link to download a typical large file.

https://nickfranksradionics.livedrive.com/item/4007d3697f5342208207495986f53db7

The missing dlls are typical qtcore4.dll, qt5gui.dll, qt5core.dll, which I can see are in camerabag directory in Programs X86

but for some reasons I keep getting messages saying one or the other cound't be found

Very strange

 

Thanks

 

Nick

Share this post


Link to post
Share on other sites

The initial release of CameraBag 2.8 for Windows was just an EXE, no installer with no DLLs. They quickly fixed that. Is it possible that the CameraBag.exe that you're trying to run isn't the one you think you're trying to run? Maybe there's a copy of the EXE somewhere else?

Share this post


Link to post
Share on other sites

Doug

 

thanks for your comments. I attach a pic of the directory I am working from, which should tell you if it's all there or not

 

Many thanks

 

NickCamerabag_directory_x86.thumb.JPG.9b9847

Share this post


Link to post
Share on other sites

That looks like a good installation. As long as that's the copy of CameraBag2.exe that you're running.

The Win7 box I'm using has the QtGui4 and other DLLs in Program Files (x86)/Intel/Intel(R) Update Manager/bin/ui. I don't know if that information helps you at all. CB2 should be using QT5, not QT4. And as you've already noted, the Qt5 DLLs are right there in your folder.

If you start CB2 by double-clicking the "CameraBag 2" entry in the folder listed above, does that work? If so, maybe however you've been launching it is launching some other copy.

You can always try uninstalling and reinstalling. Be warned that this can cause duplicate entries in CameraBag's folder in My Documents, so you might want to just rename the existing one for safekeeping.

Share this post


Link to post
Share on other sites

Doug,

 

I have uninstalled and reinstalled multiple times. I ran camerbag from the x86 folder as you suggested and as soon as I went to save (from a large file) camerabag just crashed. I attach the error message.

Also note that I installed camerbag on an entirely separate computer running W7 (as opposed to 8.1 on this one) and the same problems are apparent!

 

Thanks

 

Nick

Camerabag crash.JPG

Share this post


Link to post
Share on other sites

but if I use smaller files, let's say 13Mb or smaller, it works at the moment. However, i have had all this before - then it suddenly stops working on smaller files, even 1 - 2Mb.

Another problem is I cannot get Camerabag to include in the 'open with' list. You can add to the list, but if you try to use it to open a file, you get an error such as.....all a great pity because it used to wrok flawlessly and now it mor or less unuseable

 

Thanks

 

Nick

Camerabag error message 13.5.2016 #2.JPG

Share this post


Link to post
Share on other sites

Hi Nick, we're definitely not using Qt4 anymore, we're using Qt5, so as far as we can tell this error is almost certainly coming from an older version of CameraBag. It might be something else, but we can't figure out what on earth it might be. We don't know what to say, other than to ensure that you've definitely uninstalled every version of CameraBag before grabbing the latest install from nevercenter.com/camerabag.

Really wish we could figure this one out!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×